What’s Vulnerable › Vulnerabilities
CVE-2022-25037
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue in wanEditor v4.7.11 and fixed in v.4.7.12 and v.5 was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function.
Affected products
- Wangeditor: from 4.7.11 before 4.7.12 — fixed in 4.7.12
How to fix
Upgrade to a fixed version: Wangeditor 4.7.12. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Mdxjj/5cf0a31e8abf24ed688ceb5b3543516d
- https://github.com/wangeditor-team/wangEditor/issues/3870
- https://gist.github.com/Mdxjj/5cf0a31e8abf24ed688ceb5b3543516d
- https://github.com/wangeditor-team/wangEditor/issues/3870
Get alerted when CVE-2022-25037 or the next vulnerability affects your stack