What’s Vulnerable › Vulnerabilities
CVE-2022-2507
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of Octopus Deploy it is possible to render user supplied input into the webpage
Affected products
- Octopus Deploy Octopus Server: before 2023.1.9794; from 2022.4.0 before 2022.4.8332; from 2023.1.0 before 2023.1.6715 — fixed in 2022.4.8332, 2023.1.6715, 2023.1.9794
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.4.8332, 2023.1.6715, 2023.1.9794. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-06/
- https://advisories.octopus.com/post/2023/sa2023-06/
Get alerted when CVE-2022-2507 or the next vulnerability affects your stack