What’s Vulnerable › Vulnerabilities
CVE-2022-2509
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-10-14
- Weakness: CWE-415
Description
A vulnerability found in gnutls. This security flaw happens because of a double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35
- [UNKNOWN] gnutls: before 3.7.7 — fixed in 3.7.7
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.7.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-2509
- https://lists.debian.org/debian-lts-announce/2022/08/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6FL27JS3VM74YEQU7PGB62USO3KSBYZX/
- https://lists.gnupg.org/pipermail/gnutls-help/2022-July/004746.html
- https://www.debian.org/security/2022/dsa-5203
- https://access.redhat.com/security/cve/CVE-2022-2509
- https://lists.debian.org/debian-lts-announce/2022/08/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6FL27JS3VM74YEQU7PGB62USO3KSBYZX/
- https://lists.gnupg.org/pipermail/gnutls-help/2022-July/004746.html
- https://www.debian.org/security/2022/dsa-5203
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2022-2509 or the next vulnerability affects your stack