What’s Vulnerable › Vulnerabilities
CVE-2022-25108
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-476
Description
Foxit PDF Reader and Editor before 11.2.1 and PhantomPDF before 10.1.7 allow a NULL pointer dereference during PDF parsing because the pointer is used without proper validation.
Affected products
- Foxit PDF Reader: before 10.1.7; from 11.0 before 11.2.1 — fixed in 10.1.7, 11.2.1
- Foxit Pdf Reader: before 11.2.1 — fixed in 11.2.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.7, 11.2.1; Foxit Pdf Reader 11.2.1. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2022-25108 or the next vulnerability affects your stack