What’s Vulnerable › Vulnerabilities
CVE-2022-25139
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-416
Description
njs through 0.7.0, used in NGINX, was discovered to contain a heap use-after-free in njs_await_fulfilled.
Affected products
- F5 Njs: before 0.7.2 — fixed in 0.7.2
How to fix
Upgrade to a fixed version: F5 Njs 0.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/nginx/njs/commit/6a07c2156a07ef307b6dcf3c2ca8571a5f1af7a6
- https://github.com/nginx/njs/issues/451
- https://security.netapp.com/advisory/ntap-20220303-0007/
- https://github.com/nginx/njs/commit/6a07c2156a07ef307b6dcf3c2ca8571a5f1af7a6
- https://github.com/nginx/njs/issues/451
- https://security.netapp.com/advisory/ntap-20220303-0007/
Get alerted when CVE-2022-25139 or the next vulnerability affects your stack