What’s Vulnerable › Vulnerabilities
CVE-2022-2514: Cross-site Scripting (XSS) - Reflected in beancount/fava
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected XSS due to the lack of escaping of error messages which contained the parameters in verbatim.
Affected products
- beancount/fava: before 1.22 — fixed in 1.22
How to fix
Upgrade to a fixed version: beancount/fava 1.22. Check the vendor advisory for mitigations.
References
- https://github.com/beancount/fava/commit/ca9e3882c7b5fbf5273ba52340b9fea6a99f3711
- https://huntr.dev/bounties/dbf77139-4384-4dc5-9994-45a5e0747429
- https://github.com/beancount/fava/commit/ca9e3882c7b5fbf5273ba52340b9fea6a99f3711
- https://huntr.dev/bounties/dbf77139-4384-4dc5-9994-45a5e0747429
Get alerted when CVE-2022-2514 or the next vulnerability affects your stack