What’s Vulnerable › Vulnerabilities
CVE-2022-25171: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-78
Description
The package p4 before 0.0.7 are vulnerable to Command Injection via the run() function due to improper input sanitization
Affected products
- p4: before 0.0.7 — fixed in 0.0.7
How to fix
Upgrade to a fixed version: p4 0.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/natelong/p4/blob/master/p4.js%23L12
- https://github.com/natelong/p4/commit/ae42e251beabf67c00539ec0e1d7aa149ca445fb
- https://security.snyk.io/vuln/SNYK-JS-P4-3167330
- https://github.com/natelong/p4/blob/master/p4.js%23L12
- https://github.com/natelong/p4/commit/ae42e251beabf67c00539ec0e1d7aa149ca445fb
- https://security.snyk.io/vuln/SNYK-JS-P4-3167330
Get alerted when CVE-2022-25171 or the next vulnerability affects your stack