What’s Vulnerable › Vulnerabilities
CVE-2022-2522: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-10-08
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0061.
Affected products
- vim/vim: before 9.0.0061 — fixed in 9.0.0061
How to fix
Upgrade to a fixed version: vim/vim 9.0.0061. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/5fa9f23a63651a8abdb074b4fc2ec9b1adc6b089
- https://github.com/vim/vim/commit/b9e717367c395490149495cf375911b5d9de889e
- https://huntr.dev/bounties/3a2d83af-9542-4d93-8784-98b115135a22
- https://huntr.dev/bounties/3a2d83af-9542-4d93-8784-98b115135a22/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/5fa9f23a63651a8abdb074b4fc2ec9b1adc6b089
- https://github.com/vim/vim/commit/b9e717367c395490149495cf375911b5d9de889e
- https://huntr.dev/bounties/3a2d83af-9542-4d93-8784-98b115135a22
- https://huntr.dev/bounties/3a2d83af-9542-4d93-8784-98b115135a22/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2522 or the next vulnerability affects your stack