What’s Vulnerable › Vulnerabilities

CVE-2022-25243

Description

"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Vault 1.8.9, 1.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25243 or the next vulnerability affects your stack