What’s Vulnerable › Vulnerabilities
CVE-2022-2525: Improper Restriction of Excessive Authentication Attempts in janeczku/calibre-web
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-307
Description
Improper Restriction of Excessive Authentication Attempts in GitHub repository janeczku/calibre-web prior to 0.6.20.
Affected products
- janeczku/calibre-web: before 0.6.20 — fixed in 0.6.20
How to fix
Upgrade to a fixed version: janeczku/calibre-web 0.6.20. Check the vendor advisory for mitigations.
References
- https://github.com/janeczku/calibre-web/commit/49e4f540c9b204c7e39b3c27ceadecd83ed60e7e
- https://huntr.dev/bounties/9ff87820-c14c-4454-9764-406496254ef0
- https://github.com/janeczku/calibre-web/commit/49e4f540c9b204c7e39b3c27ceadecd83ed60e7e
- https://huntr.dev/bounties/9ff87820-c14c-4454-9764-406496254ef0
Get alerted when CVE-2022-2525 or the next vulnerability affects your stack