What’s Vulnerable › Vulnerabilities
CVE-2022-25270
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-863
Description
The Quick Edit module does not properly check entity access in some circumstances. This could result in users with the "access in-place editing" permission viewing some content they are are not authorized to access. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.
Affected products
- Drupal: from 9.2.0 before 9.2.13; from 9.3.0 before 9.3.6 — fixed in 9.2.13, 9.3.6
How to fix
Upgrade to a fixed version: Drupal 9.2.13, 9.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25270 or the next vulnerability affects your stack