What’s Vulnerable › Vulnerabilities
CVE-2022-25271
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.
Affected products
- Drupal: from 7.0.0 before 7.88; from 9.2.0 before 9.2.13; from 9.3.0 before 9.3.6 — fixed in 7.88, 9.2.13, 9.3.6
- Fedoraproject Fedora: 35, 36
How to fix
Upgrade to a fixed version: Drupal 7.88, 9.2.13, 9.3.6. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/
- https://www.drupal.org/sa-core-2022-003
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/
- https://www.drupal.org/sa-core-2022-003
Get alerted when CVE-2022-25271 or the next vulnerability affects your stack