What’s Vulnerable › Vulnerabilities
CVE-2022-25274
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-26 · updated 2026-06-17
- Weakness: CWE-863
Description
Drupal 9.3 implemented a generic entity access API for entity revisions. However, this API was not completely integrated with existing permissions, resulting in some possible access bypass for users who have access to use revisions of content generally, but who do not have access to individual items of node and media content. This vulnerability only affects sites using Drupal's revision system.
Affected products
- Drupal: from 9.3.0 before 9.3.12 — fixed in 9.3.12
How to fix
Upgrade to a fixed version: Drupal 9.3.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25274 or the next vulnerability affects your stack