What’s Vulnerable › Vulnerabilities
CVE-2022-2528
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-09 · updated 2026-06-17
- Weakness: CWE-276
Description
In affected versions of Octopus Deploy it is possible to upload a package to built-in feed with insufficient permissions after re-indexing packages.
Affected products
- Octopus Deploy Octopus Server: from 3.0.0 through 4.1.10; from 2018.1.0 through 2021.3.13021; from 2022.1.0 before 2022.1.3106; from 2022.2.6729 before 2022.2.7718; from 2022.3.348 before 2022.3.7782 — fixed in 2022.1.3106, 2022.2.7718, 2022.3.7782
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3106, 2022.2.7718, 2022.3.7782. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-13/
- https://advisories.octopus.com/post/2022/sa2022-13/
Get alerted when CVE-2022-2528 or the next vulnerability affects your stack