What’s Vulnerable › Vulnerabilities
CVE-2022-25293
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-787
Description
A systemd stack-based buffer overflow in WatchGuard Firebox and XTM appliances allows an authenticated remote attacker to potentially execute arbitrary code by initiating a firmware update with a malicious upgrade image. This vulnerability impacts Fireware OS before 12.7.2_U2, 12.x before 12.1.3_U8, and 12.2.x through 12.5.x before 12.5.9_U2.
Affected products
- WatchGuard Fireware OS: from 12.0.0 before 12.1.3; from 12.2.0 before 12.5.9; from 12.7.0 before 12.7.2; 12.1.3, 12.1.3-u1, 12.1.3-u2, 12.1.3-u3, 12.1.3-u4, 12.1.3-u5 (+6) — fixed in 12.1.3, 12.5.9, 12.7.2
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.1.3, 12.5.9, 12.7.2. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/121.html
- https://www.watchguard.com/support/release-notes/fireware/12/en-US/EN_ReleaseNotes_Fireware_12_7_2/index.html#Fireware/en-US/resolved_issues.html
- https://cwe.mitre.org/data/definitions/121.html
- https://www.watchguard.com/support/release-notes/fireware/12/en-US/EN_ReleaseNotes_Fireware_12_7_2/index.html#Fireware/en-US/resolved_issues.html
Get alerted when CVE-2022-25293 or the next vulnerability affects your stack