What’s Vulnerable › Vulnerabilities
CVE-2022-25308
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow flaw was found in the Fribidi package. This flaw allows an attacker to pass a specially crafted file to the Fribidi application, which leads to a possible memory leak or a denial of service.
Affected products
- GNU Fribidi: before 1.0.12 — fixed in 1.0.12
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: GNU Fribidi 1.0.12. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-25308
- https://bugzilla.redhat.com/show_bug.cgi?id=2047890
- https://github.com/fribidi/fribidi/issues/181
- https://github.com/fribidi/fribidi/pull/184
- https://access.redhat.com/security/cve/CVE-2022-25308
- https://bugzilla.redhat.com/show_bug.cgi?id=2047890
- https://github.com/fribidi/fribidi/issues/181
- https://github.com/fribidi/fribidi/pull/184
Get alerted when CVE-2022-25308 or the next vulnerability affects your stack