What’s Vulnerable › Vulnerabilities
CVE-2022-25327: Local Denial of Service in fscrypt PAM module
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-255
Description
The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above
Affected products
- Google LLC fscrypt: before 0.3.3 — fixed in 0.3.3
How to fix
Upgrade to a fixed version: Google LLC fscrypt 0.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25327 or the next vulnerability affects your stack