What’s Vulnerable › Vulnerabilities
CVE-2022-2537: WooCommerce PDF Invoices & Packing Slips < 3.0.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce PDF Invoices & Packing Slips WordPress plugin before 3.0.1 does not sanitise and escape some parameters before outputting them back in an attributes of an admin page, leading to Reflected Cross-Site Scripting.
Affected products
- wpovernight PDF Invoices & Packing Slips for WooCommerce: from 2.14.0 before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: wpovernight PDF Invoices & Packing Slips for WooCommerce 3.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ae613148-85d8-47a0-952d-49c29584676f
- https://wpscan.com/vulnerability/ae613148-85d8-47a0-952d-49c29584676f
Get alerted when CVE-2022-2537 or the next vulnerability affects your stack