What’s Vulnerable › Vulnerabilities
CVE-2022-25371: Unauth Path Traversal with file corruption affecting the Birt plugin of Apache OFBiz
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Apache OFBiz uses the Birt project plugin (https://eclipse.github.io/birt-website/) to create data visualizations and reports. By leveraging a bug in Birt (https://bugs.eclipse.org/bugs/show_bug.cgi?id=538142) it is possible to perform a remote code execution (RCE) attack in Apache OFBiz, release 18.12.05 and earlier.
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.06 — fixed in 18.12.06
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.06. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/09/02/7
- http://www.openwall.com/lists/oss-security/2022/09/03/1
- http://www.openwall.com/lists/oss-security/2022/09/08/2
- https://lists.apache.org/thread/bvp3sczqq863lxr1wh7wjvdtjbkcwspq
- http://www.openwall.com/lists/oss-security/2022/09/02/7
- http://www.openwall.com/lists/oss-security/2022/09/03/1
- http://www.openwall.com/lists/oss-security/2022/09/08/2
- https://lists.apache.org/thread/bvp3sczqq863lxr1wh7wjvdtjbkcwspq
Get alerted when CVE-2022-25371 or the next vulnerability affects your stack