What’s Vulnerable › Vulnerabilities
CVE-2022-25377
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-22
Description
The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APP_STORAGE_CERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)
Affected products
- appwrite/appwrite: from 0.5.0 before 0.12.2 — fixed in 0.12.2
How to fix
Upgrade to a fixed version: appwrite/appwrite 0.12.2. Check the vendor advisory for mitigations.
References
- https://dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1/
- https://github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php#L539
- https://github.com/appwrite/appwrite/pull/2780
- https://github.com/appwrite/appwrite/releases/tag/0.12.2
- https://dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1/
- https://github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php#L539
- https://github.com/appwrite/appwrite/pull/2780
- https://github.com/appwrite/appwrite/releases/tag/0.12.2
Get alerted when CVE-2022-25377 or the next vulnerability affects your stack