What’s Vulnerable › Vulnerabilities
CVE-2022-2538: WP Hide & Security Enhancer < 1.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Hide & Security Enhancer WordPress plugin before 1.8 does not escape a parameter before outputting it back in an attribute of a backend page, leading to a Reflected Cross-Site Scripting
Affected products
- WP Hide & Security Enhancer: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: WP Hide & Security Enhancer 1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/afa1e159-30bc-42d2-b3f8-8c868b113d3e
- https://wpscan.com/vulnerability/afa1e159-30bc-42d2-b3f8-8c868b113d3e
Get alerted when CVE-2022-2538 or the next vulnerability affects your stack