What’s Vulnerable › Vulnerabilities
CVE-2022-2546: All-in-One WP Migration < 7.63 - Unauthenticated Reflected XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-02 · updated 2026-06-17
Description
The All-in-One WP Migration WordPress plugin before 7.63 uses the wrong content type, and does not properly escape the response from the ai1wm_export AJAX action, allowing an attacker to craft a request that when submitted by any visitor will inject arbitrary html or javascript into the response that will be executed in the victims session. Note: This requires knowledge of a static secret key
Affected products
- servmask All-in-One WP Migration and Backup: before 7.63 — fixed in 7.63
How to fix
Upgrade to a fixed version: servmask All-in-One WP Migration and Backup 7.63. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f84920e4-a1fe-47cf-9ba5-731989c70f58
- https://wpscan.com/vulnerability/f84920e4-a1fe-47cf-9ba5-731989c70f58
Get alerted when CVE-2022-2546 or the next vulnerability affects your stack