What’s Vulnerable › Vulnerabilities
CVE-2022-2556: MailChimp for Woocommerce < 2.7.2 - Admin+ SSRF
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-918
Description
The Mailchimp for WooCommerce WordPress plugin before 2.7.2 has an AJAX action that allows high privilege users to perform a POST request on behalf of the server to the internal network/LAN, the body of the request is also appended to the response so it can be used to scan private network for example
Affected products
- Mailchimp for WooCommerce: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Mailchimp for WooCommerce 2.7.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f2a59eaa-6b44-4098-912f-823289cf33b0
- https://wpscan.com/vulnerability/f2a59eaa-6b44-4098-912f-823289cf33b0
Get alerted when CVE-2022-2556 or the next vulnerability affects your stack