What’s Vulnerable › Vulnerabilities
CVE-2022-25598: Apache DolphinScheduler user registration is vulnerable to ReDoS attacks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-1333
Description
Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 2.0.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hwnw7xr969sg5nv84wz75nfr2c76fl93
- https://lists.apache.org/thread/hwnw7xr969sg5nv84wz75nfr2c76fl93
Get alerted when CVE-2022-25598 or the next vulnerability affects your stack