What’s Vulnerable › Vulnerabilities
CVE-2022-2561
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-502
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of OPC Labs QuickOPC 2022.1. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the processing of XML files in Connectivity Explorer. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-16596.
Affected products
- OPC Labs QuickOPC: from 5.63 before 5.63.246 — fixed in 5.63.246
How to fix
Upgrade to a fixed version: OPC Labs QuickOPC 5.63.246. Check the vendor advisory for mitigations.
References
- https://kb.opclabs.com/ZDI-CAN-16596_Connectivity_Explorer_file_vulnerability
- https://www.zerodayinitiative.com/advisories/ZDI-22-1031/
- https://kb.opclabs.com/ZDI-CAN-16596_Connectivity_Explorer_file_vulnerability
- https://www.zerodayinitiative.com/advisories/ZDI-22-1031/
Get alerted when CVE-2022-2561 or the next vulnerability affects your stack