What’s Vulnerable › Vulnerabilities
CVE-2022-25618: WordPress wpDataTables plugin <= 2.1.27 - Stored Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in wpDataTables (WordPress plugin) versions <= 2.1.27
Affected products
- TMS-Plugins wpDataTables Lite: before 2.1.28 — fixed in 2.1.28
How to fix
Upgrade to a fixed version: TMS-Plugins wpDataTables Lite 2.1.28. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wpdatatables/wordpress-wpdatatables-plugin-2-1-27-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/wpdatatables/#developers
- https://patchstack.com/database/vulnerability/wpdatatables/wordpress-wpdatatables-plugin-2-1-27-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/wpdatatables/#developers
Get alerted when CVE-2022-25618 or the next vulnerability affects your stack