What’s Vulnerable › Vulnerabilities
CVE-2022-25638
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-295
Description
In wolfSSL before 5.2.0, certificate validation may be bypassed during attempted authentication by a TLS 1.3 client to a TLS 1.3 server. This occurs when the sig_algo field differs between the certificate_verify message and the certificate message.
Affected products
- wolfSSL: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: wolfSSL 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/4813
- https://www.wolfssl.com/docs/security-vulnerabilities/
- https://github.com/wolfSSL/wolfssl/pull/4813
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2022-25638 or the next vulnerability affects your stack