What’s Vulnerable › Vulnerabilities
CVE-2022-2564: Prototype Pollution in automattic/mongoose
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 31.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-28 · updated 2026-06-17
- Weakness: CWE-1321
Description
Prototype Pollution in GitHub repository automattic/mongoose prior to 6.4.6.
Affected products
- automattic/mongoose: before 5.13.15; from 6.0.0 before 6.4.6 — fixed in 5.13.15, 6.4.6
How to fix
Upgrade to a fixed version: automattic/mongoose 5.13.15, 6.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/Automattic/mongoose/blob/51e758541763b6f14569744ced15cc23ab8b50c6/lib/schema.js#L88-L141
- https://github.com/Automattic/mongoose/compare/6.4.5...6.4.6
- https://github.com/automattic/mongoose/commit/a45cfb6b0ce0067ae9794cfa80f7917e1fb3c6f8
- https://huntr.dev/bounties/055be524-9296-4b2f-b68d-6d5b810d1ddd
- https://github.com/Automattic/mongoose/blob/51e758541763b6f14569744ced15cc23ab8b50c6/lib/schema.js#L88-L141
- https://github.com/Automattic/mongoose/compare/6.4.5...6.4.6
- https://github.com/automattic/mongoose/commit/a45cfb6b0ce0067ae9794cfa80f7917e1fb3c6f8
- https://huntr.dev/bounties/055be524-9296-4b2f-b68d-6d5b810d1ddd
Get alerted when CVE-2022-2564 or the next vulnerability affects your stack