What’s Vulnerable › Vulnerabilities
CVE-2022-25640
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-295
Description
In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.
Affected products
- wolfSSL: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: wolfSSL 5.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25640 or the next vulnerability affects your stack