What’s Vulnerable › Vulnerabilities
CVE-2022-25641
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-06-17
Description
Foxit PDF Reader before 11.2.2 and PDF Editor before 11.2.2, and PhantomPDF before 10.1.8, mishandle cross-reference information during compressed-object parsing within signed documents. This leads to delivery of incorrect signature information via an Incremental Saving Attack and a Shadow Attack.
Affected products
- Foxit PDF Reader: from 11.0 before 11.2.2 — fixed in 11.2.2
- Foxit Pdf Reader: from 11.0 before 11.2.2 — fixed in 11.2.2
- Foxit Phantompdf: before 10.1.8 — fixed in 10.1.8
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.2.2; Foxit Pdf Reader 11.2.2; Foxit Phantompdf 10.1.8. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2022-25641 or the next vulnerability affects your stack