What’s Vulnerable › Vulnerabilities
CVE-2022-25642
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Obyte (formerly Byteball) Wallet before 3.4.1 allows XSS. A crafted chat message can lead to remote code execution.
Affected products
- Obyte: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Obyte 3.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/byteball/obyte-gui-wallet/releases/tag/v3.4.1
- https://obyte.org/faq
- https://vuln.ryotak.me/advisories/64
- https://github.com/byteball/obyte-gui-wallet/releases/tag/v3.4.1
- https://obyte.org/faq
- https://vuln.ryotak.me/advisories/64
Get alerted when CVE-2022-25642 or the next vulnerability affects your stack