What’s Vulnerable › Vulnerabilities
CVE-2022-25643
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-668
Description
seatd-launch in seatd 0.6.x before 0.6.4 allows removing files with escalated privileges when installed setuid root. The attack vector is a user-supplied socket pathname.
Affected products
- Seatd Project Seatd: from 0.6.0 before 0.6.4 — fixed in 0.6.4
How to fix
Upgrade to a fixed version: Seatd Project Seatd 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/kennylevinsen/seatd/commit/10658dc5439db429af0088295a051c53925a4416
- https://github.com/kennylevinsen/seatd/commit/7cffe0797fdb17a9c08922339465b1b187394335
- https://github.com/kennylevinsen/seatd/compare/0.6.3...0.6.4
- https://github.com/kennylevinsen/seatd/tags
- https://lists.sr.ht/~kennylevinsen/seatd-announce/%3CETEO7R.QG8B1KGD531R1%40kl.wtf%3E
- https://nvd.nist.gov/vuln/detail/CVE-2022-25643
- https://github.com/kennylevinsen/seatd/commit/10658dc5439db429af0088295a051c53925a4416
- https://github.com/kennylevinsen/seatd/commit/7cffe0797fdb17a9c08922339465b1b187394335
- https://github.com/kennylevinsen/seatd/compare/0.6.3...0.6.4
- https://github.com/kennylevinsen/seatd/tags
- https://lists.sr.ht/~kennylevinsen/seatd-announce/%3CETEO7R.QG8B1KGD531R1%40kl.wtf%3E
- https://nvd.nist.gov/vuln/detail/CVE-2022-25643
Get alerted when CVE-2022-25643 or the next vulnerability affects your stack