What’s Vulnerable › Vulnerabilities
CVE-2022-25647: Deserialization of Untrusted Data
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-01 · updated 2026-06-17
- Weakness: CWE-502
Description
The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Google Gson: from 2.2.3 before 2.8.9 — fixed in 2.8.9
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- Oracle Financial Services Crime And Compliance Management Studio: 8.0.8.2.0, 8.0.8.3.0
- Oracle Corporation GraalVM Enterprise Edition: 20.3.6, 21.3.2, 22.1.0
- Oracle Retail Order Broker: 18.0, 19.1
How to fix
Upgrade to a fixed version: Google Gson 2.8.9. Check the vendor advisory for mitigations.
References
- https://github.com/google/gson/pull/1991
- https://github.com/google/gson/pull/1991/commits
- https://lists.debian.org/debian-lts-announce/2022/05/msg00015.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00009.html
- https://security.netapp.com/advisory/ntap-20220901-0009/
- https://snyk.io/vuln/SNYK-JAVA-COMGOOGLECODEGSON-1730327
- https://www.debian.org/security/2022/dsa-5227
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://github.com/google/gson/pull/1991
- https://github.com/google/gson/pull/1991/commits
- https://lists.debian.org/debian-lts-announce/2022/05/msg00015.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00009.html
Get alerted when CVE-2022-25647 or the next vulnerability affects your stack