What’s Vulnerable › Vulnerabilities
CVE-2022-25649: WordPress Affiliate For WooCommerce premium plugin <= 4.7.0 - Multiple Improper Access Control vulnerabilities
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-05 · updated 2026-06-17
- Weakness: CWE-264
Description
Multiple Improper Access Control vulnerabilities in StoreApps Affiliate For WooCommerce premium plugin <= 4.7.0 at WordPress.
Affected products
- StoreApps Affiliate For WooCommerce (WordPress plugin): before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: StoreApps Affiliate For WooCommerce (WordPress plugin) 4.8.0. Check the vendor advisory for mitigations.
References
- https://dzv365zjfbd8v.cloudfront.net/changelogs/affiliate-for-woocommerce/changelog.txt
- https://patchstack.com/database/vulnerability/affiliate-for-woocommerce/wordpress-affiliate-for-woocommerce-premium-plugin-4-7-0-multiple-improper-access-control-vulnerabilities
- https://dzv365zjfbd8v.cloudfront.net/changelogs/affiliate-for-woocommerce/changelog.txt
- https://patchstack.com/database/vulnerability/affiliate-for-woocommerce/wordpress-affiliate-for-woocommerce-premium-plugin-4-7-0-multiple-improper-access-control-vulnerabilities
Get alerted when CVE-2022-25649 or the next vulnerability affects your stack