What’s Vulnerable › Vulnerabilities
CVE-2022-2571: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0101.
Affected products
- vim/vim: before 9.0.0101 — fixed in 9.0.0101
How to fix
Upgrade to a fixed version: vim/vim 9.0.0101. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/a6f9e300161f4cb54713da22f65b261595e8e614
- https://huntr.dev/bounties/2e5a1dc4-2dfb-4e5f-8c70-e1ede21f3571
- https://github.com/vim/vim/commit/a6f9e300161f4cb54713da22f65b261595e8e614
- https://huntr.dev/bounties/2e5a1dc4-2dfb-4e5f-8c70-e1ede21f3571
Get alerted when CVE-2022-2571 or the next vulnerability affects your stack