What’s Vulnerable › Vulnerabilities
CVE-2022-2572
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-287
Description
In affected versions of Octopus Server where access is managed by an external authentication provider, it was possible that the API key/keys of a disabled/deleted user were still valid after the access was revoked.
Affected products
- Octopus Deploy Octopus Server: from 3.5 before 2022.1.3264; from 2022.2.6729 before 2022.2.8277; from 2022.3.348 before 2022.3.10586; from 2022.4.791 before 2022.4.2898 — fixed in 2022.1.3264, 2022.2.8277, 2022.3.10586, 2022.4.2898
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3264, 2022.2.8277, 2022.3.10586, 2022.4.2898. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-23/
- https://advisories.octopus.com/post/2022/sa2022-23/
Get alerted when CVE-2022-2572 or the next vulnerability affects your stack