What’s Vulnerable › Vulnerabilities
CVE-2022-2574: Meks Easy Social Share < 1.2.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Meks Easy Social Share WordPress plugin before 1.2.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Meks Easy Social Share: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: Meks Easy Social Share 1.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9dec8ac7-befd-4c9d-9a9e-7da9e395dbf2
- https://wpscan.com/vulnerability/9dec8ac7-befd-4c9d-9a9e-7da9e395dbf2
Get alerted when CVE-2022-2574 or the next vulnerability affects your stack