What’s Vulnerable › Vulnerabilities
CVE-2022-25757: Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-28 · updated 2026-06-17
- Weakness: CWE-20
Description
In Apache APISIX before 2.13.0, when decoding JSON with duplicate keys, lua-cjson will choose the last occurred value as the result. By passing a JSON with a duplicate key, the attacker can bypass the body_schema validation in the request-validation plugin. For example, `{"string_payload":"bad","string_payload":"good"}` can be used to hide the "bad" input. Systems satisfy three conditions below are affected by this attack: 1. use body_schema validation in the request-validation plugin 2. upstream application uses a special JSON library that chooses the first occurred value, like jsoniter or gojay 3. upstream application does not validate the input anymore. The fix in APISIX is to re-encode the validated JSON input back into the request body at the side of APISIX. Improper Input Validation vulnerability in __COMPONENT__ of Apache APISIX allows an attacker to __IMPACT__. This issue affects Apache APISIX Apache APISIX version 2.12.1 and prior versions.
Affected products
- Apache Software Foundation Apache APISIX: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 2.13.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/03/28/2
- https://lists.apache.org/thread/03vd2j81krxmpz6xo8p1dl642flpo6fv
- http://www.openwall.com/lists/oss-security/2022/03/28/2
- https://lists.apache.org/thread/03vd2j81krxmpz6xo8p1dl642flpo6fv
Get alerted when CVE-2022-25757 or the next vulnerability affects your stack