What’s Vulnerable › Vulnerabilities
CVE-2022-25759: Remote Code Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-94
Description
The package convert-svg-core before 0.6.2 are vulnerable to Remote Code Injection via sending an SVG file containing the payload.
Affected products
- convert-svg-core: before 0.6.2 — fixed in 0.6.2
How to fix
Upgrade to a fixed version: convert-svg-core 0.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/neocotic/convert-svg/commit/7e6031ac7427cf82cf312cb4a25040f2e6efe7a5
- https://github.com/neocotic/convert-svg/issues/81
- https://github.com/neocotic/convert-svg/pull/82
- https://security.snyk.io/vuln/SNYK-JS-CONVERTSVGCORE-2849633
- https://github.com/neocotic/convert-svg/commit/7e6031ac7427cf82cf312cb4a25040f2e6efe7a5
- https://github.com/neocotic/convert-svg/issues/81
- https://github.com/neocotic/convert-svg/pull/82
- https://security.snyk.io/vuln/SNYK-JS-CONVERTSVGCORE-2849633
Get alerted when CVE-2022-25759 or the next vulnerability affects your stack