What’s Vulnerable › Vulnerabilities

CVE-2022-25761: Denial of Service (DoS)

Description

The package open62541/open62541 before 1.2.5, from 1.3-rc1 and before 1.3.1 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Affected products

How to fix

Upgrade to a fixed version: open62541 1.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25761 or the next vulnerability affects your stack