What’s Vulnerable › Vulnerabilities
CVE-2022-25766: Remote Code Execution (RCE)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 34.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-88
Description
The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.
Affected products
- ungit: before 1.5.20 — fixed in 1.5.20
How to fix
Upgrade to a fixed version: ungit 1.5.20. Check the vendor advisory for mitigations.
References
- https://github.com/FredrikNoren/ungit/blob/master/CHANGELOG.md%231520
- https://github.com/FredrikNoren/ungit/pull/1510
- https://snyk.io/vuln/SNYK-JS-UNGIT-2414099
- https://github.com/FredrikNoren/ungit/blob/master/CHANGELOG.md%231520
- https://github.com/FredrikNoren/ungit/pull/1510
- https://snyk.io/vuln/SNYK-JS-UNGIT-2414099
Get alerted when CVE-2022-25766 or the next vulnerability affects your stack