What’s Vulnerable › Vulnerabilities
CVE-2022-25768: Improper Access Control in UI upgrade process
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-287
Description
The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required.
Affected products
- Mautic: from 1.1.3 before 4.4.13; from 5.0.0 before 5.1.1 — fixed in 4.4.13, 5.1.1
How to fix
Upgrade to a fixed version: Mautic 4.4.13, 5.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25768 or the next vulnerability affects your stack