What’s Vulnerable › Vulnerabilities
CVE-2022-25770: Insufficient authentication in upgrade flow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-306
Description
Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.
Affected products
- Mautic: from 1.0.1 before 4.4.13; from 5.0.0 before 5.1.1; 1.0.0, 1.0.0-beta3, 1.0.0-beta4, 1.0.0-rc1, 1.0.0-rc2, 1.0.0-rc3 (+1) — fixed in 4.4.13, 5.1.1
How to fix
Upgrade to a fixed version: Mautic 4.4.13, 5.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-25770 or the next vulnerability affects your stack