What’s Vulnerable › Vulnerabilities
CVE-2022-25788
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-19 · updated 2026-10-08
- Weakness: CWE-787
Description
A maliciously crafted JT file in Autodesk AutoCAD 2022 may be used to write beyond the allocated buffer while parsing JT files. This vulnerability can be exploited to execute arbitrary code.
Affected products
- Autodesk Advance Steel: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD: from 2022 before 2022.1.2; from 2022 before 2022.2.2 — fixed in 2022.1.2, 2022.2.2
- Autodesk AutoCAD Architecture: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD Electrical: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD LT: from 2022 before 2022.1.2; from 2022 before 2022.2.2 — fixed in 2022.1.2, 2022.2.2
- Autodesk AutoCAD MAP 3D: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD Mechanical: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD MEP: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk AutoCAD Plant 3D: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk Civil 3D: from 2022 before 2022.1.2 — fixed in 2022.1.2
- Autodesk Inventor: from 2022 before 2022.2 — fixed in 2022.2
How to fix
Upgrade to a fixed version: Autodesk Advance Steel 2022.1.2; Autodesk AutoCAD 2022.1.2, 2022.2.2; Autodesk AutoCAD Architecture 2022.1.2; Autodesk AutoCAD Electrical 2022.1.2; Autodesk AutoCAD LT 2022.1.2, 2022.2.2; Autodesk AutoCAD MAP 3D 2022.1.2; Autodesk AutoCAD Mechanical 2022.1.2; Autodesk AutoCAD MEP 2022.1.2; Autodesk AutoCAD Plant 3D 2022.1.2; Autodesk Civil 3D 2022.1.2; Autodesk Inventor 2022.2. Check the vendor advisory for mitigations.
References
- https://www.autodesk.com/trust/security-advisories/adsk-sa-2022-0002
- https://www.autodesk.com/trust/security-advisories/adsk-sa-2022-0002
Get alerted when CVE-2022-25788 or the next vulnerability affects your stack