What’s Vulnerable › Vulnerabilities
CVE-2022-2580: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0102.
Affected products
- vim/vim: before 9.0.0102 — fixed in 9.0.0102
How to fix
Upgrade to a fixed version: vim/vim 9.0.0102. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/1e56bda9048a9625bce6e660938c834c5c15b07d
- https://huntr.dev/bounties/c5f2f1d4-0441-4881-b19c-055acaa16249
- https://github.com/vim/vim/commit/1e56bda9048a9625bce6e660938c834c5c15b07d
- https://huntr.dev/bounties/c5f2f1d4-0441-4881-b19c-055acaa16249
Get alerted when CVE-2022-2580 or the next vulnerability affects your stack