What’s Vulnerable › Vulnerabilities
CVE-2022-2581: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.0104.
Affected products
- vim/vim: before 9.0.0104 — fixed in 9.0.0104
How to fix
Upgrade to a fixed version: vim/vim 9.0.0104. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/f50940531dd57135fe60aa393ac9d3281f352d88
- https://huntr.dev/bounties/0bedbae2-82ae-46ae-aa68-1c28b309b60b
- https://github.com/vim/vim/commit/f50940531dd57135fe60aa393ac9d3281f352d88
- https://huntr.dev/bounties/0bedbae2-82ae-46ae-aa68-1c28b309b60b
Get alerted when CVE-2022-2581 or the next vulnerability affects your stack