What’s Vulnerable › Vulnerabilities
CVE-2022-25813: Server-Side Template Injection affecting the ecommerce plugin of Apache OFBiz
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 67.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-1336
Description
In Apache OFBiz, versions 18.12.05 and earlier, an attacker acting as an anonymous user of the ecommerce plugin, can insert a malicious content in a message “Subject” field from the "Contact us" page. Then a party manager needs to list the communications in the party component to activate the SSTI. A RCE is then possible.
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.06 — fixed in 18.12.06
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.06. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/09/02/4
- https://lists.apache.org/thread/vmj5s0qb59t0lvzf3vol3z1sc3sgyb2b
- http://www.openwall.com/lists/oss-security/2022/09/02/4
- https://lists.apache.org/thread/vmj5s0qb59t0lvzf3vol3z1sc3sgyb2b
Get alerted when CVE-2022-25813 or the next vulnerability affects your stack