What’s Vulnerable › Vulnerabilities
CVE-2022-2584: Panic when decoding invalid blocks in github.com/ipld/go-codec-dagpb
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-119
Description
The dag-pb codec can panic when decoding invalid blocks.
Affected products
- github.com/ipld/go-codec-dagpb: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: github.com/ipld/go-codec-dagpb 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/ipld/go-codec-dagpb/commit/a17ace35cc760a2698645c09868f9050fa219f57
- https://pkg.go.dev/vuln/GO-2022-0422
- https://github.com/ipld/go-codec-dagpb/commit/a17ace35cc760a2698645c09868f9050fa219f57
- https://pkg.go.dev/vuln/GO-2022-0422
Get alerted when CVE-2022-2584 or the next vulnerability affects your stack