What’s Vulnerable › Vulnerabilities
CVE-2022-25850: Server-side Request Forgery (SSRF)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-01 · updated 2026-06-17
- Weakness: CWE-918
Description
The package github.com/hoppscotch/proxyscotch before 1.0.0 are vulnerable to Server-side Request Forgery (SSRF) when interceptor mode is set to proxy. It occurs when an HTTP request is made by a backend server to an untrusted URL submitted by a user. It leads to a leakage of sensitive information from the server.
Affected products
- github.com/hoppscotch/proxyscotch: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: github.com/hoppscotch/proxyscotch 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/hoppscotch/proxyscotch/commit/de67380f62f907f201d75854b76024ba4885fab7
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMHOPPSCOTCHPROXYSCOTCH-2435228
- https://github.com/hoppscotch/proxyscotch/commit/de67380f62f907f201d75854b76024ba4885fab7
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMHOPPSCOTCHPROXYSCOTCH-2435228
Get alerted when CVE-2022-25850 or the next vulnerability affects your stack