What’s Vulnerable › Vulnerabilities
CVE-2022-25851: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-10 · updated 2026-06-17
- Weakness: CWE-835
Description
The package jpeg-js before 0.4.4 are vulnerable to Denial of Service (DoS) where a particular piece of input will cause to enter an infinite loop and never return.
Affected products
- jpeg-js: before 0.4.4 — fixed in 0.4.4
How to fix
Upgrade to a fixed version: jpeg-js 0.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/jpeg-js/jpeg-js/commit/9ccd35fb5f55a6c4f1902ac5b0f270f675750c27
- https://github.com/jpeg-js/jpeg-js/issues/105
- https://github.com/jpeg-js/jpeg-js/pull/106/
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2860295
- https://snyk.io/vuln/SNYK-JS-JPEGJS-2859218
- https://github.com/jpeg-js/jpeg-js/commit/9ccd35fb5f55a6c4f1902ac5b0f270f675750c27
- https://github.com/jpeg-js/jpeg-js/issues/105
- https://github.com/jpeg-js/jpeg-js/pull/106/
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2860295
- https://snyk.io/vuln/SNYK-JS-JPEGJS-2859218
Get alerted when CVE-2022-25851 or the next vulnerability affects your stack